[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#4980: libc.so.5.4.7 breaks mcopy from ext2fs to win95

'Hal Brand wrote:'
>>Hal Brand writes:
>>> With libc.so.5.4.7, "mcopy myfile.txt f:/" fails. Reverting to libc.so.5.2.18
>>> allows mcopy to work. Interestingly enough, "mdir f:" works with
>>> both 5.4.7 and 5.2.18!
>>Strange. I never experienced problems with that. Could you track down the
>>problem in mcopy? I'd really like to know which function is reporting this.
>Looks like I can't track it down. I tried, but with no success. I fetched
>the latest sources, configured, compiled, and tested - no problems
>with libc.so.5.4.7. My best *guess* at this point is a change in a symbolic
>constant rendering any version compiled a while ago unviable with the
>new library. However, this probably means that the mtools package should
>be updated.

Did you try a vfat filesystem?  I have no problems with mtools-3.0-5
under libc5-5.4.7-4 which I just installed now that we have decided to
use it (but I don't use any vfat filesystems).

Christopher J. Fearnley            |    Linux/Internet Consulting
cjf@netaxs.com, cjf@onit.net       |    UNIX SIG Leader at PACS
http://www.netaxs.com/~cjf         |    (Philadelphia Area Computer Society)
ftp://ftp.netaxs.com/people/cjf    |    Design Science Revolutionary
"Dare to be Naive" -- Bucky Fuller |    Explorer in Universe

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: