[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Packaging philosophy question:


	I think if the kernel versions 1.3.97+ have the proper code
 included, the depends should be on the virtual packages kernel-image
 and/or kernel-source (or just kernel-headers maybe? Nothing older
 than 1.3.97 provides kernel-image etc AFAIK (please correct me if I'm
 wrong). I think that building n the version numbers maybe a bad idea,
 given how often Linus updates the kernels.


>>"Dirk" == Dirk Eddelbuettel <Dirk.Eddelbuettel@qed.econ.queensu.ca> writes:

Dirk> Hi Oli

Dirk> Great that you follow-up on the pcmcia discussion by maintaining
Dirk> the package!  In short, I would do the following

Dirk> * name the $(package)-$(version).$(arch).deb, something like
Dirk>   pcmcia-cs-2.8.12-0.i386.deb

Dirk> * add a Depends: kernel-image-1.3.97 | kernel-source-1.3.97 to
Dirk>   debian.control as Simon has just released these. That should
Dirk>   allow you to sit back and not have to update weekly as I heard
Dirk>   good things about 1.3.97 (I am still at 1.3.93). You need of
Dirk>   course to compile it under 1.3.97 yourself.
Dirk> Otherwise, look through the Packaging Guidelines, read some
Dirk> *diff.gz files (these contain all debian.* files) from recently
Dirk> posted packages to see what others did, and simply ask more
Dirk> questions here. Oh, and make sure you are subscribed to
Dirk> debian-{devel,private}.

"I believe I found the missing link between animal and civilized
man. It is us."  -- Konrad Lorenz 
Manoj Srivastava               Systems Research Programmer, Project Pilgrim,
Phone: (413) 545-3918                A143B Lederle Graduate Research Center,
Fax:   (413) 545-1249         University of Massachusetts, Amherst, MA 01003
<srivasta@pilgrim.umass.edu> <URL:http://www.pilgrim.umass.edu/%7Esrivasta/>

Reply to: