[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: aout programs cannot get users' password entries

> > > It works fine for me using the current a.out packages.  Please send me
> > > the output from 'dpkg -l', 'ldd user.aout', your user.aout
> > > (uuencoded), and optionally, a sanitized version of your /etc/passwd.
> > 
> > ...
> > - -- /etc/passwd (sanitized) --
> > ...
> > nobody:*:65534:65534:nobody:/dev/null
> You are missing a ':' at the end of this line.  A quick check of the
> passwd(5) manpage on a couple of systems did not shed any light on
> whether or not this should be allowed.  Bruce, the current base
> package is missing the ':' also and should be updated regardless.

Wow. I totally missed that. I did get that line by merging the new
passwd file from the most recent base, so that was the source of the
problem. I guess the routines in libc5 tolerate this error while those
in libc4 do not.

An interesting note: I ran the most recent passwd script for the first
time just after sending you that email. In the process of changing a
user's passwd, it stripped out the "nobody" line, apparently because it
was illegal. I didn't notice this until I got your reply and tried to
add the ':' to that line.

Thanks again for your efforts. Bruce, too.

> David
> -- 
> David Engel                        Optical Data Systems, Inc.
> david@ods.com                      1101 E. Arapaho Road
> (214) 234-6400                     Richardson, TX  75081

Reply to: