[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#2640: dpkg 1.1.3 hoses the dpkg subsystem in certain cases

Package: dpkg
Version: 1.1.3

Boy, I been posting too many "my system got hosed messages" lately :(

I think we solved the dependency and pre-dependency issues for an ELF
dpkg.  But an a.out dpkg NEEDS "depends: libc | libc4" or there will be
BIG trouble (I'm re-installing again :(  Fortunately, it's a test
system, but I need it for a demo Tuesday :(

Anyway what happened is that I installed the new ELF boot-disks and
then NFS mounted my mirror of the unstable tree.  Then in the base
subdirectory I did "dpkg -i *" and when dpkg got "upgraded" my system
didn't have any a.out support and dpkg was toast.  [An unrelated bug is
that ~5 packages in base failed to install properly when I tried this
technique on my desktop system (which fortunately has a.out support).]

I'm beginning to seriously question the sanity of leaving out ANY
implicit dependencies.  I've been burned too many times lately due to
these ommissions.  Then again, I'm often guilty of trying to push
systems to their limits to learn where the boundaries are (however
painful this sometimes is).  Clearly it is not a fail-safe approach.

Christopher J. Fearnley            |    UNIX SIG Leader at PACS
cjf@netaxs.com                     |    (Philadelphia Area Computer Society)
http://www.netaxs.com/~cjf         |    Design Science Revolutionary
ftp://ftp.netaxs.com/people/cjf    |    Explorer in Universe
"Dare to be Naive" -- Bucky Fuller |    Linux Advocate

Reply to: