[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Internal compiler error

At 22:22 4/02/96 -0500, you wrote:
>I have seen this problem reported before---it was mentioned
>several times in the archives:
>> gcc -D__KERNEL__ -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -pipe 
>>   -m486 -c module.c
>> gcc: Internal compiler error: program cc1 got fatal signal 11
>> make[1]: *** [module.o] Error 1
>> make[1]: Leaving directory '/usr/src/linux/kernel'
>> make: *** [linuxsubdirs] Error 1
>This is happening to me on a new pentium. I can't compile
>the kernel at all.  This has happened with everything I've 
>tried this weekend:
>    gcc 2.6.3 and 2.7.0
>    ELF and a.out
>    running kernels (all 1.2.13) compiled with gcc 2.6 and 2.7
>    Debian 0.93 R6, Debian 1.0 (oops), and Slackware 3.0
>(By the way, Caldera didn't even get that far:  I kept getting
>"NULL pointer reference in kernel" or something like that.)
>Also, at one point I had the entire Debian system installed and
>was able to run X, but odd things happened like segmentation 
>faults in X and fvwm, and funny errors about bad X messages. 
>Here is the hardware:
>   Pentium 133 (Triton)
>   256K PB cache
>   32 MB (it should be EDO, but I'm sure right now) 
>   Maxtor 1.6 GB
>   Acer 6x ATAPI cd-rom
>   ATI Pro Turbo 2MB
>   Sound Blaster AWE 32
>   Cheap NE2000 
>(It would be but-kickin machine, if it worked. :)
>I'm thinking that this is problem with the motherboard, but
>that is just a guess.  Any other ideas? 
>  robert

Hmmm - I love long quoting :-)

Ok, I've fixed that problem.  It's not a very good way to fix it - but in
the CMOS setup you've got to dis-enable write-back caching in favour of
write-through caching.  I think it's actually something to do with some PCI
machines (this error of mine is happening on a pci 486dx4/100) and changing
the CMOS like that fixes it.

On my other Linux box I have write back caching on (isa 486dx50) and it's
fine, so <shrug> it's working, and perhaps all-be-it a bit slower, but at
least it IS working.


Karl Ferguson <karl@tower.com.au>                Tel: +61-9-455-3446
                                                 Fax: +61-9-455-2776
Network Supervisor,
Tower Networking Pty Ltd (ACN: 072 322 760)   | Internet Providers and |
T/A STAR Online Services                      |  Networking Solutions  |

Reply to: