[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Internal compiler error

I have seen this problem reported before---it was mentioned
several times in the archives:

> gcc -D__KERNEL__ -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -pipe 
>   -m486 -c module.c
> gcc: Internal compiler error: program cc1 got fatal signal 11
> make[1]: *** [module.o] Error 1
> make[1]: Leaving directory '/usr/src/linux/kernel'
> make: *** [linuxsubdirs] Error 1

This is happening to me on a new pentium. I can't compile
the kernel at all.  This has happened with everything I've 
tried this weekend:
    gcc 2.6.3 and 2.7.0
    ELF and a.out
    running kernels (all 1.2.13) compiled with gcc 2.6 and 2.7
    Debian 0.93 R6, Debian 1.0 (oops), and Slackware 3.0

(By the way, Caldera didn't even get that far:  I kept getting
"NULL pointer reference in kernel" or something like that.)

Also, at one point I had the entire Debian system installed and
was able to run X, but odd things happened like segmentation 
faults in X and fvwm, and funny errors about bad X messages. 

Here is the hardware:
   Pentium 133 (Triton)
   256K PB cache
   32 MB (it should be EDO, but I'm sure right now) 
   Maxtor 1.6 GB
   Acer 6x ATAPI cd-rom
   ATI Pro Turbo 2MB
   Sound Blaster AWE 32
   Cheap NE2000 

(It would be but-kickin machine, if it worked. :)

I'm thinking that this is problem with the motherboard, but
that is just a guess.  Any other ideas? 


Reply to: