Bug#2059: dpkg and depend on versions
> Erick Branderhorst writes ("Bug#2059: dpkg and depend on versions"):
> > Package: dpkg
> > Version: 1.0.8
> > I installed the man package (2.3.10-6) succesfully. After that I tried
> > to upgrade the libgdbm1 package (1.7.3-8). During installation of
> > libgdbm1 dpkg reports about libgdbm1 conflicting with man (<2.3.10-6)
> > and that man (version 2.3.10-5) is installed.
> Are you absolutely sure that this is what it is doing ? Was the thing
> below an actual session transcript ? I find it hard to imagine where
> it got the `5' from ...
Yes, I'm sure, the transcription was in chronological order. I didn't understand
the `5' either.
I was thinking that perhaps the < was causing it?
Is the conflicting version number calculated from (<2.3.10-6) or is it
displayed right away after reading it from the status file. I should have
send the status file probably but I think it is too late now.
> Note that < means less-than-or-equal-to in this context.
Erick Branderhorst@heel.fgg.eur.nl +31-10-4635142
Department of General Surgery (Intensive Care) University Hospital Rotterdam NL