[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#2059: dpkg and depend on versions

Package: dpkg
Version: 1.0.8

I installed the man package (2.3.10-6) succesfully. After that I tried
to upgrade the libgdbm1 package (1.7.3-8). During installation of
libgdbm1 dpkg reports about libgdbm1 conflicting with man (<2.3.10-6)
and that man (version 2.3.10-5) is installed.

- Why is it reporting the wrong version of an installed package and
therefore the conflict?


# dpkg --status man
Package: man
Status: install ok installed
Priority: important
Section: doc
Maintainer: Alvar Bray <alvar@meiko.co.uk>
Version: 2.3.10
Revision: 6
Depends: groff, libc5, libgdbm1

# dpkg --status libgdbm1
Package: libgdbm1
Status: install ok installed
Maintainer: Ray Dassen <jdassen@wi.LeidenUniv.nl>
Version: 1.7.3
Revision: 6
Provides: elf-libgdbm, libgdbm
Depends: libc5 (>5.2.16-1)
Conflicts: libgdbm

# dpkg -i /root/debian/stable/binary/devel/libgdbm1-1.7.3-8.deb
dpkg: regarding .../stable/binary/devel/libgdbm1-1.7.3-8.deb containing libgdbm1:
 libgdbm1 conflicts with man (<2.3.10-6)
  man (version 2.3.10-5) is installed.
dpkg: error processing /root/debian/stable/binary/devel/libgdbm1-1.7.3-8.deb (--install):
 conflicting packages - not installing libgdbm1
Errors were encountered while processing:
Erick Branderhorst@heel.fgg.eur.nl +31-10-4635142
Department of General Surgery (Intensive Care) University Hospital Rotterdam NL

Reply to: