[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#2036: Printer stuck #2.

1. I didn't have lp installed since the installation parameter screen
for this said "line printer", not just "printer".

Having been a computer operator in times past I KNOW my little HP Deskjet 500
is NO "line printer".

2. I ran: insmod lp
the result:

Module:        #pages:  Used by:
lp                 2

Address  Symbol         Defined by
0082c060 _lp_table      [lp]

In fact, I used insmod, rmmod, lsmod, ksyms all a couple of times each or
more, and looked at the man pages, too.

I am happy to report that the '500 now responds to its OWN Reset button
and does the Power On Reset.

I must regretfully add that that is all of the progress made.

3. lsmod >/dev/lp0
returns: "bash: /dev/lp0: No such device"
and I was logged in as root, too.

Using lp1 or lp2 is no help.

4. Additionally, I had forgotten to mention that the Print Screen button on this
key board works with MS-DOS, but NEVER with Debian yet. (A real pain for a
Linux novice trying to work around this bug by copying various help and data
screens down by HAND! Especially during installation.)

That Print Screen button still doesn't work.

Thanks for all the help. It's going to take a LOT of it to get Debian up to
a Plug -n- Play appliance standard. This printer problem is just one of many.


The above reflects the observations of myself only, unless stated otherwise.

Eddie Maddox, Amateur Lobbyist      "Great spirits have always encountered
maddo005@gold.tc.umn.edu             violent opposition from mediocre minds."
P.O. Box 75321
St Paul MN 55175-0321                                       Albert Einstein

Reply to: