[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#1791: dosemu troubles

Package: dosemu
Version: 0.60.3-0

Hi Dirk,

I hope you don't mind me entering your comments (and my additional
comments) as another debian bug report.  Hopefully, documenting these
problems will prevent a lot of redundant bug reports.

On Wed, 1 Nov 95 16:14 EST, Dirk.Eddelbuettel@qed.econ.queensu.ca said:

> Hi Mike
> sorry to bother but I am fighting dosemu to no avail.
> using xdos, I get the following error in the rxvt from which I start xdos
>	ERROR: video error(0x3 page>7: 43)
> xdos works but is awfully slow (eg in Quicken it takes a second until the
> cursor responds to pressing the cursor keys)

Same here.  Quicken is really the only dos app I'm interested in and
it's dead-dog slow under xdos.  I haven't tried playing with the
"hogthreshold".  That might help, though.

> using dos on the console and with TERM=linux, I have weird problems
> with the keyboard. Cursor keys sometimes work, sometimes they
> don't. Activating numlock helps.

Strange.  I have not experienced this one.  My problems on VCs are the

o no cursor
o when I switch back to a running X session, the X session dies and
  xdm starts another, which dies, etc., etc.

> on the console, I have a very hard time to set the mouse up. It's
> an old logitech 3button that I used for years. If I remember
> corrrecly, I used it dosemu 0.52 with no problems. I tried the
> internal driver that I use under X11, the logitech driver I used
> for years and a new logitech driver I just grabbed from Simtel.

There are some mouse drivers on tsx-11 under the dosemu directory.
You might try those, too.

> Thanks for providing the Debian package and I hope you don't mind me
> bombarding you with these unsollicited questions.

I'm pretty stressed with school so don't expect too much from me.  :-/

> #serial { mouse  com 1 device /dev/mouse }  <-- I tried various combinations
> #mouse { logitech internaldriver }          <-- of these settings, xdos
> #serial { com 4  device /dev/modem }        <-- works these commented out

That's strange.  James just told me something about needing to comment
these out, too.  I didn't realize that it was required to get xdos to
work (I thought he was talking about running on the VC).  On my system
xdos works, even when I have a mouse enabled.  The fact that
performance is so hardware-dependent sure makes supporting dosemu an
interesting job!  :-/

I'm cc'ing this to James.  Hopefully, the additional information will


PS:  James, the above comments all apply to the dosemu 0.60.3 package I
     compiled for Debian.

Reply to: