[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problems with elv-vi package install

Bill Mitchell writes ("problems with elv-vi package install"):
> dpkg introduced update-alternatives, nvi used it, elvis
> followed suit (I don't know about the other vi clones).
> Installation of both nvi and elvis will now fail in
> a messy and unhelpful manner with older dpkg versions.
> I'll update elvis to fail more gracefully by suggesting a dpkg
> update if update-alternatives isn't present.

How about:
 Package: elv-vi
 Depends: dpkg (>0.93.72)

This will make dpkg produce an informative message without even having
to run your script.


Reply to: