[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#1167: ELF development packages fail or have missing dependencies

Package: elf-gcc
Version: 2.7.0-1

chiark:~/junk> gcc-elf -Wall -O3 t.cc
bash: /usr/bin/gcc-elf: No such file or directory
chiark:~/junk> strace /usr/bin/gcc-elf
strace: exec: No such file or directory
chiark:~/junk> cat /proc/version
Linux version 1.2.10 (ian@chiark) (gcc version 2.6.3) #1 Sat Jul 15 13:28:33 BST 1995
chiark:~/junk> grep ELF /usr/src/linux-1.2.10/.config
chiark:~/junk> dpkg -l '*elf*'
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required
||/ Name         Version   Rev  Description
ii  elf-binutils 2.5.2l.17 1    The GNU assembler and binary utilities (ELF).
ii  elf-gcc          2.7.0 1    The GNU compiler (ELF).
ii  elf-libc         5.0.9 1    The Linux C library version 5 (ELF).

Reading /usr/bin/gcc-elf in less I see the string `/lib/ld-linux.so'
very close to the beginning.  /lib/ld-linux.so does not exist on my


PS: "dpkg -l '*elf*'" will only work with the new C dpkg.

Reply to: