[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: I have updated chipmunk to the latest release



On Mon, Aug 11, 2014 at 9:17 PM, Vincent Cheng <vcheng@debian.org> wrote:
Hi Andrew,

On Mon, Aug 11, 2014 at 5:40 PM, Andrew Kelley <superjoe30@gmail.com> wrote:
> Hello debian games team,
>
> I have taken the liberty to update the chipmunk debian package to the latest
> release (6.2.1). I also took a lot of liberty and converted to git and made
> some other executive decisions. Excerpt from changelog follows:

This isn't a thorough review, I just quickly skimmed your packaging to
address some of your changelog entries:

Thank you for that.
 

>   * enable multi arch

The shared lib package needs to declare Pre-Depends:
${misc:Pre-Depends} (that effectively adds a pre-dependency on
multiarch-support).

Good catch. This is now fixed.
 
Also, libchipmunk-dev cannot be made MA: same
as-is because it ships an arch-dependent file in a non-multiarch path
(/usr/bin/chipmunk_demos) and thus isn't co-installable. You can
either drop the MA: same declaration, or ship that arch-dependent file
in a separate package (e.g. libchipmunk-bin or -tools). 

I looked into this, and it looks like upstream is not building the binary files by default anymore. So no binaries are produced for the demos. I think this avoids the issue.
 

>   * rename chipmunk-dev to libchipmunk-dev for consistency

libchipmunk-dev needs to breaks+replaces chipmunk-dev (Policy 7.6.1
[1]; if you want to know why this is needed, try installing both
packages). Also, you should keep chipmunk-dev around as a transitional
package until at least one stable release has passed, to provide an
upgrade path for chipmunk-dev -> libchipmunk-dev.

Instead I reverted that particular change. Does that work for you?

Regards,
Andrew


Reply to: