[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: même programme en GTK 1.2 et GTK 2.0 dans le même paquet ?



Ludovic Rousseau <ludovic.rousseau@free.fr> writes:

> Je maintiens le paquet jpilot qui est une application GTK 1.2. Le support
> de GTK 2.0 n'est pas encore terminé mais il est possible de compiler
> l'application avec --enable-gtk2 pour avoir une application
> fonctionnelle (le « seul » problème concerne le texte avec lettres
> accentuées donc ça ne gène pas tout le monde).

Certainement pango qui râle car il ne peut pas afficher des textes non
encodés en UTF-8.  Ça concerne quand même tous les utilisateurs sauf
les anglophones !


> Que dois-je faire ?
> 1. compiler avec gtk2 et me prendre plein de rapport de bugs ?
> 2. laisser tomber ce bug #196821 pour l'instant
> 3. créer un paquet jpilot2 avec l'application compiler pour gtk2
> 4. avoir dans le même paquet jpilot les binaires pour gtk 1.2 et gtk 2.0 ?
> 
> Les 3 premières solutions ne me conviennent pas vraiment.
> Est-ce que la 4ème solution est jouable/souhaitable/une connerie ?

Personnellement, je choisirais la deuxième solution.  Un utilisateur
peut ne pas être content, mais si le portage n'est pas stable, autant
attendre plutôt que de se compliquer la vie.  

La quatrième solution n'est pas envisageable car elle duplique les
dépendances, donc force à avoir les deux versions de GTK installées
simultanément.  Quand à la troisième, c'est encombrer l'archive Debian
pour pas grand chose.

A+

-- 
o Benjamin Drieu:       bdrieu@april.org
                        benj@grassouille.org
o APRIL:                http://www.april.org/

Attachment: pgpwvDlzpT_FP.pgp
Description: PGP signature


Reply to: