[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

options de compilation



Bonjour,

J'utilise Caudium comme serveur web, qui me donne satisfaction.
Sauf que j'aimerais l'utiliser avec PHP + PostgreSQL.

Quelques détails sur le problèmes :
	http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=181175

Après deux semaines sans réponse, j'ai essayé de me prendre par la main
pour recompiler le paquet :
	- récupération du paquet source php4.
	- récupération des paquets « -dev » nécessaires.
	  Pas facile du tout, entre autres à cause des paquets qui
	  changent de noms, comme libmagick5-dev qui semble devenir
	  libmagick-dev en sid, libpng2-dev qui est maintenant
	  libpng12-dev... En tout, 59 paquets à ajouter. (Je précise que
	  je suis sur un mixte sarge/sid.) J'ai heureusement l'ADSL.
	- retouche de debian/control pour adapter les changements des
	  noms des paquets.
	- essai de modif de debian/rules pour ne pas compiler tous les
	  paquets issus du source.
	- dpkg-buildpackage... Et échec sur :
	  	configure: error: cannot find necessary header file(s)
	  	make: *** [configure-caudium-stamp] Erreur 1
	- nouvel essai, sans la modif de debian/rules, même échec.
	- Là, je sèche.
	
Me voilà bien avancé... :/


Mes petites réflexions, soumises à votre réaction :
	- Les options de compilations des paquets sont loin d'être
	  innocentes. On ne peut pas dire qu'il « suffit » de recompiler
	  avec les options de son choix. Pas avec tous les paquets en
	  tout cas !
	- Comment faire pour avoir l'avis du responsable du paquets ?
	  (Mon problème ne concerne ni Caudium, ni PHP, mais leur
	  intégration par Debian.)


Et si vous avez des propositions pour mon problème, je suis preneur !


merci

benoit

Attachment: pgpPMGNpRtIo6.pgp
Description: PGP signature


Reply to: