[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

multi-antÚportage



Salut,

Dans la série des jeux idiots, j'en ai un sympa. J'ai besoin de faire
un paquet Debian de LyX 0.1. Pas de problème, j'ai les sources dans la
Debian 1.3.

Moyennant une bricole (pas très propre) dans le ./configure (je chunte
le test de détection de la lib xforms qui ne marche pas... alors que
j'ai « multi-anté-porté » la version 0.81 qui est sensée fonctionner
avec cette version de LyX et que le test ne voit pas), le make se
plante :

# make
[...]
paragraph.C:27: ANSI C++ forbids declaration `paragraph_id' with no
type

(le programme est en C++ et j'utilise gcc de la Patate).

Bon, je me doute que la norme a évolué donc je voudrai avoir une
option qui permette de me retrouver avec un environnement équivalent
de l'époque (en ce qui concerne la permissivité de g++).

Par défaut, il y avait :

make LDFLAGS=-s CXX="g++" CXXFLAGS="-g -O2"

et j'ai essayé 

make LDFLAGS=-s CXX="g++" CXXFLAGS="-g -O2 -traditional"

mais avec le même succès.

Est-ce que quelqu'un pourrait m'aider svp ?

Merci d'avance.

PK

PS : abstenez-vous du conseil de passer à une autre version de LyX :
c'est celle-là qu'il me faut.

PPS : Georges, t'es battu sur ce coup-là... Passer de Debian 1.3
directement à 2.2 est encore plus tordu que le rétroportage de Woody
sur Potato ;-)

-- 
      |\      _,,,---,,_       Patrice KARATCHENTZEFF
ZZZzz /,`.-'`'    -.  ;-;;,_   mailto:p.karatchentzeff@free.fr
     |,4-  ) )-,_. ,\ (  `'-'  http://p.karatchentzeff.free.fr
    '---''(_/--'  `-'\_)       



Reply to: