[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#682010: re celt and mumble referred to the TC


On Thursday 19 July 2012 14:40:28 Chris Knadle wrote:
> ... except that Nicos Gollan stated that mumble servers have a base
> assumption that clients have the CELT 0.7.1 codec available.  :-/  Is that
> correct?

If a client does not report any CELT versions, the server assumes that (only) 
0.7.1 is available for that client. If a client reports a number of supported 
versions, and 0.7.1 is not among them, the server will _not_ make the 
assumption, but of course such clients also risk being unable to communicate.

For details, see the implementations of:

* Server::msgAuthenticate()
* Server::recheckCodecVersions()

Newer git versions of the server will send upon login a warning to clients 
which are either missing CELT support on a "normal" server, or OPUS support on 
an OPUS-only server.


Reply to: