Re: Please make it easier to detect fai-diskimage
>>>>> On Thu, 10 Nov 2016 07:41:53 -0500, Sam Hartman <firstname.lastname@example.org> said:
> I think you need a new action, a new variable, or a subroutine like
> ifclass. If you want to minimize variables, introducing a short
> subroutine seems like a reasonable way to encapsulate the test if a new
> action ends up being bad for other reasons.
I like the idea of a new subroutine like ifclass.
I need some help with a useful name of such a function.
For testing if FAI is running from the nfsroot (testing do_init_tasks
-eq 1) what about names like:
Any better name? What do you think is most descriptive?
Any proposal for a name fo a test if fai-diskimage calles fai? (action
= install a not running from nfsroot)
I'm really bad at choosing good names for subroutines. Please help me.
> It's important to have stable tests for things like this because users
> will copy this into configspaces. You can't refactor their code for
Since I will add some test subroutines, we only need stable names for