[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Jessie Vagrant/VirtualBox image stuck booting ?

Hi Olivier,

On 12 April 2016 at 09:27, Olivier Berger
<olivier.berger@telecom-sudparis.eu> wrote:
> Hi.
> I've tried to generate a Vagrant box with bootstrap-vz (master branch
> latest) which worked.
> However, after vagrant init / vagrant up, the boot doesn't work so well:
> the VM boots, but gets stuck at :
>  Loading Linux 3.16.0-4-amd64 ...
>  Loading initial ramdisk ...
> I've tried with the latest packaged version of bootstrap-vz in testing,
> without much difference :-/

I was able to successfully build the example "jessie-vagrant.yml"[1],
both on an outdated[2] and an updated[3] on a Jessie machine, and
start the box afterwards, using the latest code from the upstream
master branch. Can you share you manifest and build logs?

> Maybe that's an issue with latest jessie update that has nothing to do
> with bootstrap-vz...
> Any clue ?

This is something that I have been talking with Marcin Kulisz, as we
are facing build problems after the latest Jessie update, but we
suspect that it affects the package (0.9.0-1) from the repository[4],
not builds from the upstream code. For instance, I wasn't able to
build a machine based on
(changing the release to "jessie" and updating the location of the
VirtualBox Guest Additions ISO). The following error is raised in the
"Installing grub" task:

CalledProcessError: Command 'chroot /target/74cdb45c/root grub-install
/dev/dm-0' returned non-zero exit status 1

I guess this fix can be backported from upstream[5] as a non-intrusive
change that could be included in a future jessie-proposed-update. I'll
look further into this.

Anyway, this doesn't looks like what you are facing, because you had
no problems in building the machine, only when starting the Vagrant
box, right? Are you sure that this isn't a problem with VirtualBox
(e.g. their modules were properly built when updating to the latest
kernel? Has it rebooted after the last upgrade?)? Are you able to boot
other virtual machines with no problem?


[1]: https://github.com/andsens/bootstrap-vz/blob/83b7839/manifests/examples/virtualbox/jessie-vagrant.yml
[2]: http://paste.debian.net/432374/
[3]: http://paste.debian.net/432375/
[4]: https://packages.debian.org/jessie/bootstrap-vz
[5]: https://github.com/andsens/bootstrap-vz/pull/163

Tiago "Myhro" Ilieve
Blog: https://blog.myhro.info/
GitHub: https://github.com/myhro
LinkedIn: https://br.linkedin.com/in/myhro
Montes Claros - MG, Brasil

Reply to: