[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#844459: autopkgtest: Please add autopkgtest-virt-uchroot

Hi Martin,

Quoting Martin Pitt (2016-12-08 17:59:44)
> Johannes Schauer [2016-11-16 17:32 +0100]:
> > For example, most notably, "mount -t proc proc /proc" never worked without
> > doing the systemcalls manually using the perl script I present there. This
> > problem of course might also have been due to remaining bugs in the tools I
> > used (including my kernel) which are long fixed now.
> Apparently they aren't yet (tested on Linux 4.8 and util-linux
> 2.29), or I'm missing some magic option. I also tried various
> variations like
>   unshare --propagation private -rmU --mount-proc sh -c 'whoami; findmnt /mnt'
> So as that still seems too brittle, let's go ahead with lxc-*; this
> can be changed later on to use util-linux tools once they become sufficiently
> powerful.

thanks for playing around with it. I also would've liked this to work without
the lxc package but as you can say, this can be fixed at a later point.

For things to maybe become a bit more light-weight I proposed a patch to the
lxc source package which splits out those two applications into their own
binary package. See #847491.


cheers, josch
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: signature
URL: <http://lists.alioth.debian.org/pipermail/autopkgtest-devel/attachments/20161208/ecac95d0/attachment.sig>

Reply to: