[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#800161: autopkgtest: when using adt-run with --changes, there should be a warning or error if the .changes file does not include a .dsc



Package: autopkgtest
Version: 3.17.2
Severity: normal

Hi,

when running a command like:

adt-run --changes mypkg_1.0-1_amd64.changes --- schroot unstable-amd64-sbuild

on a .changes file which does not include a .dsc (as produced by
sbuild), then the only output is:

adt-run [17:13:35]: version @version@
adt-run [17:13:35]: host hoothoot; command line: /usr/bin/adt-run --changes mypkg_1.0-1_amd64.changes --- schroot unstable-amd64-sbuild
adt-run [17:13:42]: testbed dpkg architecture: amd64
adt-run [17:13:42]: testbed running kernel: Linux 4.0.0-2-amd64 #1 SMP Debian 4.0.5-1 (2015-06-16)

and then adt-run exits successfully.

This caused quite some head-scratching on my end because I expected the
autopkg tests to be run and did not know what was missing.

adt-run should print a warning or error if its input is not sufficient
to run the tests.

Thanks!

cheers, josch




-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'buildd-unstable'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.0.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages autopkgtest depends on:
ii  apt-utils       1.0.10.2
ii  libdpkg-perl    1.18.3
ii  procps          2:3.3.10-4
ii  python3         3.4.3-4
ii  python3-debian  0.1.27

Versions of packages autopkgtest recommends:
pn  autodep8  <none>

Versions of packages autopkgtest suggests:
ii  lxc          1:1.0.7-10
ii  qemu-system  1:2.3+dfsg-6a
ii  qemu-utils   1:2.3+dfsg-6a
ii  schroot      1.6.10-2

-- no debconf information



Reply to: