[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

adt-run sh: 1: cd: can't cd to .

On 20/09/15 15:51, Martin Pitt wrote:
> Hello Christopher,
> Christopher Baines [2015-09-20 10:38 +0100]:
>> I am having some issues running adt-run. I have attached the relevant
>> part of the output, and below is the command that I ran.
>> $ adt-run --apt-upgrade build-area/*.deb test-pkg// -ddd --shell-fail
>> --- lxc adt-wheezy
> Do you run this command as root? You don't use lxc --sudo, and
> Debian's LXC packages don't support user containers (very well).

Thanks for your prompt response! But yes, I did run this as root.

>> + cd .
>> sh: 1: cd: can't cd to .
>> adt-run: DBG: testbed command exited with code 2
> This seems unrelated to LXC. Just to make sure, do you get the same
> with "null"?
> At first sight I'd say you are running adt-run from a current
> directory which does not yet exist any more. Perhaps a build tree that
> got removed in a different shell?

This command is run in the testbed, so the directory in which adt-run
should have no effect (on this issue)?

I managed to work out where the failing command was coming from, and
have attached a patch that fixed this issue for me.

Also, I was having some issues with apt resolving the dependencies, and
noticed there might be a missing call to run_shell after line 464. I
don't know if you had any tips? When I got the shell to work, I tried
installing aptitude, and that did succeed in installing the dependencies.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-cd-rather-than-cd-.-as-that-does-not-seem-to-work.patch
Type: text/x-patch
Size: 1037 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/autopkgtest-devel/attachments/20150920/ae8b536a/attachment.bin>

Reply to: