[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#1024346: cdrom: debian-11.5.0-amd64-netinst.iso boots to Grub CLI on Dell Optiplex 5090

On Thu, Nov 17, 2022 at 04:46:30PM -0500, Rob Klingsten wrote:
> Package: cdrom
> Severity: important
> Tags: d-i
> Dear Maintainer,
> *** Reporter, please consider answering these questions, where appropriate ***
>    * What led up to the situation?
>    * What exactly did you do (or not do) that was effective (or
>      ineffective)?
>    * What was the outcome of this action?
>    * What outcome did you expect instead?
> *** End of the template - remove these template lines ***
> Downloaded debian-11.5.0-amd64-netinst.iso, verified SHA512 signature and flashed to USB stick (dd if=<debian.iso> of=/dev/sdb). The
> Dell Optiplex 5090 is a UEFI-only system. In the BIOS, I previously disabled TPM, Secure Boot and Absolute (computer Lojack).
> Booting from the netinst USB stick, the computer boots into the Grub CLI. 'ls' shows the following:
> (proc) (hd0) (hd0,gpt4) (hd0,gpt3) (hd0,gpt2) (hd0,gpt1) (cd0) (cd0,msdos2)
> There does not appear to be any usable partition detected on the USB stick that contains a kernel. The contents of (cd0,msdos2) are
> just an 'efi' directory.
> I have tried multiple USB sticks, downloaded the ISO several times all with a good SHA512, tried dd and also cp <iso> /dev/sdb, makes
> no difference. I've tried the live Gnome image as well, same problem.
> I expect the computer to boot properly into the Debian installer.

First of all:

It may be better to use a longer dd line and also to use the unofficial
firmware image available at https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/11.5.0+nonfree/amd64/iso-cd/firmware-11.5.0-amd64-netinst.iso

dd if=firmware-11.5.0-amd64-netinst.iso of=/dev/sdb bs=4M oflag=sync status=progress

That makes absolutely sure that the transfer is synced to ensure that it is
written to the stick and also gives you some idea of how well the transfer
is going.

Using the firmware .iso will potentially solve any problems with missing 

The writing to a stick *should* work well.

All the very best, as ever,

Andy Cater

Reply to: