[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#789600: marked as done (cdimage.debian.org: Missing 'part_gpt' in Release ISO's GRUB EFI -> Debian 8.0 cannot be booted from GPT/FAT32 drive in UEFI mode)

Your message dated Fri, 01 Jan 2016 18:04:24 +0000
with message-id <E1aF43s-0007O5-A5@franck.debian.org>
and subject line Bug#789600: fixed in debian-installer 20160101
has caused the Debian Bug report #789600,
regarding cdimage.debian.org: Missing 'part_gpt' in Release ISO's GRUB EFI -> Debian 8.0 cannot be booted from GPT/FAT32 drive in UEFI mode
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

789600: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=789600
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: cdimage.debian.org
Severity: important
Tags: newcomer

Dear Maintainers,

It appears that the Debian 8.0 "Jessie" ISO release uses a GRUB binary that
doesn't embed the 'part_gpt' GRUB module.

Because of this, if you happen to copy the "Jessie" ISO content onto a FAT32
drive (eg: USB Flash Drive) that was partitioned using GPT, you will end up
with the GRUB rescue prompt when booting on a UEFI system, as GRUB will not be
able to locate the installation files on the GPT drive.

Note that this is only an issue if you copy content into an installation media
that is GPT: If you use 'dd' to create the installation media from the
ISOHybrid, or copy the content to a FAT32 drive that uses the MBR partition
scheme, then the problem does not occur.

Looking at the GRUB EFI binary's strings from the ISO, it seems that 'part_gpt'
was not embedded, which in turn prevents the embedded 'grub.cfg' from locating
the '/.disk/info' marker during the search for the root media, as it cannot
access GPT volumes.

I'm hoping that the GRUB EFI binary can be modified for next ISO release to
include 'part_gpt', as this should prevent this issue.

The expectation is that Windows users, who may have heard that simply copying
the Debian ISO content on a FAT32 drive should work with UEFI systems (and who
prefer using that method because they find DD/image tools a bit daunting), will
encounter this issue if they happen to copy the ISO data onto a drive that was
partitioned in GPT mode.
This is also a problem for Windows USB installation tools, such as Rufus, if
you set the USB partition scheme to GPT, as it also uses the ISO -> FAT32 copy

* What led up to the situation?
  Trying to install Debian 8.0 in UEFI mode on an intel NUC (D54250WYK), after
copying the whole ISO content to an USB drive with a single GPT/FAT32

* What exactly did you do (or not do) that was effective (or ineffective)?
  Tried to use the GRUB rescue prompt, but was unable access the USB disk.
  After recreating the USB installation media using an MBR/FAT32 partition, I
found that it worked, which demonstrates that this is a GPT vs MBR partition
scheme issue.
  Finally, looking at the GRUB binary on the Release ISO, it seems pretty clear
that the 'part_gpt' module is missing, which I believe is required, even in
UEFI mode, to access GPT partitioned drives.



-- System Information:
Debian Release: 8.1
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

--- End Message ---
--- Begin Message ---
Source: debian-installer
Source-Version: 20160101

We believe that the bug you reported is fixed in the latest version of
debian-installer, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 789600@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Cyril Brulebois <kibi@debian.org> (supplier of updated debian-installer package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@ftp-master.debian.org)

Hash: SHA1

Format: 1.8
Date: Fri, 01 Jan 2016 18:46:41 +0100
Source: debian-installer
Binary: debian-installer
Architecture: source
Version: 20160101
Distribution: unstable
Urgency: medium
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Cyril Brulebois <kibi@debian.org>
 debian-installer - Debian Installer documentation
Closes: 722735 789600 803711 805321 807716 808875 809301
 debian-installer (20160101) unstable; urgency=medium
   [ Karsten Merker ]
   * Provide u-boot and SD-card images for the LinkSprite pcDuino.
   [ Cyril Brulebois ]
   * Adjust p-u support to handle file:// instead of (f|ht)tp:// only,
     thanks to Łukasz Stelmach for both the report and the patch
     (Closes: #803711).
   [ Samuel Thibault ]
   * Bump hurd kernel version.
   * Prevent spurious speech synthesis boot entry.
   [ Vagrant Cascadian ]
   * bootscr.mainline_common: Prefer newer u-boot distro_bootpart variable.
   [ Cyril Brulebois ]
   * Cherry-pick the following changes by Steven Chamberlain from the
     jessie-kfreebsd branch.
   * build/Makefile: Rename GZIP into gzip, and pass an extra -T to pigz
     (it needs both -n and -T to behave as gzip's -n).
   * build/config/x86.cfg: Also pass -n to gzip.
   * Bump linux kernel version from 4.2.0-1 to 4.3.0-1
   * Replace the module-init-tools build-dep with a kmod one since the
     transitional package got dropped in kmod/22-1.
   * Apply patch from gregor herrmann to fix new warnings with perl 5.22
     (Closes: #808875). Thanks!
   * Update copyright years on the F10 help screen.
   * Update translation-status for the release.
   [ Steven Chamberlain ]
   * Improve reproducibility of debian-installer netboot images
     (Closes: #805321):
   * Add a new utility build/util/gen-tarball to make reproducible
     tarballs, and use it for:
     - netboot.tar.gz
     - debian-cd_info.tar.gz
     - the overall debian-installer-images tar.gz file.
   * Inhibit gzip timestamp in initrd.gz
   * Ensure SOURCE_DATE_EPOCH is exported throughout the build system,
     define it if unset, or fall back to 'now' if build/Makefile is
     directly invoked.
   [ Steve McIntyre ]
   * Add the part_gpt module into the core grub image to make it easier
     for users doing slightly different things with our images; include
     support for GPT partition tables as well as msdos (Closes: #789600).
   [ Ben Hutchings ]
   * Include leds-modules on armhf if available
   * Update i386 config to use 686 kernel flavour instead of 586
   [ Martin Michlmayr ]
   * Update docs to reflect that Package-Type and Installer-Menu-Item
     are official fields nowadays (Closes: #807716).
   * Remove minix-modules from the orion5x network-console image since
     it was only required by the D-Link DNS-323, a device that's no longer
   * Exclude usb-serial-modules from the armel network-console image
     since it's not useful there (Closes: #809301).
   * Exclude usb-modules explicitly on armel/orion5x network-console
     to work around a bug in util/pkg-list.
   * Stop including sata and ext2/ext3 modules on the armel/orion5x
     network-console image due to size limitations on QNAP TS-x09.
   * Drop the file extension from the initrd for QNAP devices.
   * Re-introduce installer images for QNAP TS-x09.
   * Recognize /dev/disk1_1 and /dev/ls_disk1_1 as boot devices
     on Linkstation.  Thanks Roger Shimizu (Closes: 722735).
   [ John Paul Adrian Glaubitz ]
   * Set KERNELVERSION for sparc64 to $(LINUX_KERNEL_ABI)-sparc64.
   * Set KEYRING to debian-ports on sparc64.
   * Add silo to Build-Depends on sparc64.
   * Fix typo (problimatic -> problematic) in silo comment.
   * Clone boot configuration files from sparc for sparc64.
 074a49d56a672decc393e828d9dbccba07401181 3434 debian-installer_20160101.dsc
 1e62df10d9e2b81b56e925e4f18a295129a724fa 1375522 debian-installer_20160101.tar.gz
 5a4e8ccfb5670bc3514a1c2f2acdca91f58c99efd2bde7ee38bb3eb2499d415a 3434 debian-installer_20160101.dsc
 257c7a0d4c04486fce0ed46dd1a0d5441770b4f67ec93966e0ae64c7dd65644b 1375522 debian-installer_20160101.tar.gz
 95fcf40227dbffcdf13ead8f3ceea1e3 3434 devel optional debian-installer_20160101.dsc
 ac785dca4dd335627e345c66bfc4ca88 1375522 devel optional debian-installer_20160101.tar.gz

Version: GnuPG v1


--- End Message ---

Reply to: