[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#789600: marked as done (cdimage.debian.org: Missing 'part_gpt' in Release ISO's GRUB EFI -> Debian 8.0 cannot be booted from GPT/FAT32 drive in UEFI mode)

Your message dated Mon, 18 Jan 2016 11:47:07 +0000
with message-id <E1aL8H5-00011G-GW@franck.debian.org>
and subject line Bug#789600: fixed in debian-installer 20150422+deb8u3
has caused the Debian Bug report #789600,
regarding cdimage.debian.org: Missing 'part_gpt' in Release ISO's GRUB EFI -> Debian 8.0 cannot be booted from GPT/FAT32 drive in UEFI mode
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

789600: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=789600
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: cdimage.debian.org
Severity: important
Tags: newcomer

Dear Maintainers,

It appears that the Debian 8.0 "Jessie" ISO release uses a GRUB binary that
doesn't embed the 'part_gpt' GRUB module.

Because of this, if you happen to copy the "Jessie" ISO content onto a FAT32
drive (eg: USB Flash Drive) that was partitioned using GPT, you will end up
with the GRUB rescue prompt when booting on a UEFI system, as GRUB will not be
able to locate the installation files on the GPT drive.

Note that this is only an issue if you copy content into an installation media
that is GPT: If you use 'dd' to create the installation media from the
ISOHybrid, or copy the content to a FAT32 drive that uses the MBR partition
scheme, then the problem does not occur.

Looking at the GRUB EFI binary's strings from the ISO, it seems that 'part_gpt'
was not embedded, which in turn prevents the embedded 'grub.cfg' from locating
the '/.disk/info' marker during the search for the root media, as it cannot
access GPT volumes.

I'm hoping that the GRUB EFI binary can be modified for next ISO release to
include 'part_gpt', as this should prevent this issue.

The expectation is that Windows users, who may have heard that simply copying
the Debian ISO content on a FAT32 drive should work with UEFI systems (and who
prefer using that method because they find DD/image tools a bit daunting), will
encounter this issue if they happen to copy the ISO data onto a drive that was
partitioned in GPT mode.
This is also a problem for Windows USB installation tools, such as Rufus, if
you set the USB partition scheme to GPT, as it also uses the ISO -> FAT32 copy

* What led up to the situation?
  Trying to install Debian 8.0 in UEFI mode on an intel NUC (D54250WYK), after
copying the whole ISO content to an USB drive with a single GPT/FAT32

* What exactly did you do (or not do) that was effective (or ineffective)?
  Tried to use the GRUB rescue prompt, but was unable access the USB disk.
  After recreating the USB installation media using an MBR/FAT32 partition, I
found that it worked, which demonstrates that this is a GPT vs MBR partition
scheme issue.
  Finally, looking at the GRUB binary on the Release ISO, it seems pretty clear
that the 'part_gpt' module is missing, which I believe is required, even in
UEFI mode, to access GPT partitioned drives.



-- System Information:
Debian Release: 8.1
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

--- End Message ---
--- Begin Message ---
Source: debian-installer
Source-Version: 20150422+deb8u3

We believe that the bug you reported is fixed in the latest version of
debian-installer, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 789600@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Cyril Brulebois <kibi@debian.org> (supplier of updated debian-installer package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@ftp-master.debian.org)

Hash: SHA1

Format: 1.8
Date: Mon, 18 Jan 2016 05:04:12 +0100
Source: debian-installer
Binary: debian-installer
Architecture: source
Version: 20150422+deb8u3
Distribution: jessie
Urgency: medium
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Cyril Brulebois <kibi@debian.org>
 debian-installer - Debian installer
Closes: 789600 796591 803711 809301
 debian-installer (20150422+deb8u3) jessie; urgency=medium
   [ Samuel Thibault ]
   * Add beep to UEFI x86 boot menu (Closes: #796591).
   * Add 's' shortcut for speech to UEFI x86 boot menu.
   [ Steve McIntyre ]
   * Add the part_gpt module into the core grub image to make it easier
     for users doing slightly different things with our images; include
     support for GPT partition tables as well as msdos (Closes: #789600).
   [ Martin Michlmayr ]
   * Exclude usb-serial-modules from the armel network-console image
     since it's not useful there (Closes: #809301).
   * Exclude usb-modules explicitly on armel/orion5x network-console
     to work around bug in util/pkg-list.
   * Drop the file extension from the initrd for QNAP devices.
   * Re-introduce installer images for QNAP TS-x09.
   * Provide u-boot images for plug computers.
   [ Cyril Brulebois ]
   * Adjust p-u support to handle file:// instead of (f|ht)tp:// only,
     thanks to Łukasz Stelmach for both the report and the patch
     (Closes: #803711).
 b055c21cfb7b87ad191a744285e463dca147e9cc 3534 debian-installer_20150422+deb8u3.dsc
 ca046b35d13fdaa5b0bdbb0dc68232a25e992d18 1375587 debian-installer_20150422+deb8u3.tar.gz
 2a50c6bdcda9d28f0f0da8fa3215c976101f4e0147bbb2fcda19e47d3b1b264e 3534 debian-installer_20150422+deb8u3.dsc
 8a87a1a54448e7c4906d34bd9c2ff8a5d399e7bacee5263f243fe48392708620 1375587 debian-installer_20150422+deb8u3.tar.gz
 6f1c2aa48b60794782dbcb31750f6008 3534 devel optional debian-installer_20150422+deb8u3.dsc
 6ced954ae844cfe70df83fa29309e2ea 1375587 devel optional debian-installer_20150422+deb8u3.tar.gz

Version: GnuPG v1


--- End Message ---

Reply to: