[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#687949: sort_deps does not track package versions

Package: debian-cd
Version: 3.1.10
Severity: serious

It seems we've had a bug designed into debian-cd ever since it
started. The dependency sorting code in tools/sort_deps does not track
versions of packages when considering if dependencies are met. For a
long time, this has seemingly worked OK. However, in the recent wheezy
d-i beta 2 build we generated discs that failed testing because of
this. Specifically, the case that broke was libseed-gtk3-0:

$ apt-cache show libseed-gtk3-0 | less
Package: libseed-gtk3-0
Source: seed
Version: 3.2.0-1
Installed-Size: 834
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Architecture: amd64
Depends: libatk1.0-0 (>= 1.12.4), libc6 (>= 2.7), libcairo-gobject2 (>= 1.10.0), libcairo2 (>= 1.8.0), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.78), libffi5 (>= 3.0.4), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libgirepository-1.0-1 (>= 0.9.2), libglib2.0-0 (>= 2.24.0), libgmp10, libgtk-3-0 (>= 3.0.0), libjavascriptcoregtk-3.0-0 (>= 1.5.1), libmpfr4 (>= 3.1.0), libpango1.0-0 (>= 1.14.0), libreadline6 (>= 6.0), libsqlite3-0 (>= 3.5.9), libxml2 (>= 2.7.4), gnome-js-common, gir1.2-glib-2.0, gir1.2-clutter-1.0, gir1.2-gstreamer-0.10 | libgstreamer0.10-0 (<< 0.10.25-3), gir1.2-gtk-3.0

The OR dependency

  gir1.2-gstreamer-0.10 | libgstreamer0.10-0 (<< 0.10.25-3)

shows the problem: libgstreamer was already selected for inclusion,
but at version 0.10.36-1. sort_deps accepted this as fulfilling the
required dependencies for libseed-gtk3-0, leaving out

Later on in testing, apt tried to install packages and could not
install libseed-gtk3-0 -> brokenness.

I already have most of the work done that is needed to fix this, but
it also depends on a patch being accepted in apt-cache (#218995).

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages debian-cd depends on:
ii  apt                                
ii  bc                                           1.06.95-2+b1
ii  bzip2                                        1.0.6-4
ii  cpp                                          4:4.7.1-1
ii  curl                                         7.26.0-1
ii  dctrl-tools [grep-dctrl]                     2.22.2
ii  dpkg-dev                                     1.16.8
ii  genisoimage                                  9:1.1.11-2
pn  libdigest-md5-perl                           <none>
ii  libdigest-sha-perl                           5.71-1
ii  libio-compress-perl [libcompress-zlib-perl]  2.052-1
ii  lynx-cur                                     2.8.8dev.12-2
ii  make                                         3.81-8.2
ii  perl [libdigest-sha-perl]                    5.14.2-12
ii  tofrodos                                     1.7.9.debian.1-1
ii  xorriso                                      1.2.2-2

Versions of packages debian-cd recommends:
ii  hfsutils         3.2.6-11
ii  netpbm           2:10.0-15+b1
ii  syslinux-common  2:4.05+dfsg-6

debian-cd suggests no packages.

-- no debconf information

Reply to: