[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#655070: cdrom: lilo installer forgot to include the initial ramdisk

Package: cdrom
Severity: important

Dear Maintainer,
during installation I selected to boot via LILO becaus eof another bug in the grub2 installer.
The LILO installation worked fine but the system was not able to boot because the initrd.img file
was missing in lilo.conf.
I tried the installation a second time but encountered the same problem again.
I found some log messages that might be helpful:

Jan  6 22:33:21 in-target: Entpacken von lilo (aus .../l/lilo/lilo_23.2-2_i386.deb) ...
Jan  6 22:33:22 in-target: Trigger für man-db werden verarbeitet ...
Jan  6 22:33:23 in-target: Trigger für menu werden verarbeitet ...
Jan  6 22:33:24 in-target: lilo (1:23.2-2) wird eingerichtet ...
Jan  6 22:33:25 in-target: WARNING: Added option 'large-memory', please run 'lilo' before you reboot.
Jan  6 22:33:25 in-target: +  boot = /dev/disk/by-id/ata-SAMSUNG_HN-M101MBB_S2R8J9BB610746
Jan  6 22:33:25 in-target: +  root = "UUID=210a8753-5f21-46cb-b5a2-b71dec711bc8"
Jan  6 22:33:25 in-target: WARNING: If boot / root options were converted, please run 'lilo' before you reboot.
Jan  6 22:33:25 in-target: Running lilo...
Jan  6 22:33:25 in-target: Warning: 
Jan  6 22:33:25 in-target: LBA32 addressing assumed
Jan  6 22:33:25 in-target: 
Jan  6 22:33:27 in-target: Added Linux  *
Jan  6 22:33:27 in-target: Skipping /vmlinuz.old
Jan  6 22:33:27 in-target: Added Windows
Jan  6 22:33:27 in-target: One warning was issued.

I had to modify the lilo.conf file manually to fix the problem:

        initrd=/initrd.img    <-- Add this line
#       restricted
#       alias=1

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 3.1.0-1-686-pae (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Reply to: