[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#249323: marked as done (offer rescue option)

Your message dated Wed, 9 May 2007 23:21:40 +0100
with message-id <20070509222140.GQ6063@einval.com>
and subject line Closing old bugs
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports

Debian-installer-version: http://cdimage.debian.org/pub/cdimage-testing/ \
  sarge_d-i/i386/beta4/sarge-i386-netinst.iso (2004-04-30)
uname -a: 
Date: 2004-05-16; 15:00 EET
Method: Base system from CD, network install after boot; used
  ftp.fi.debian.org as mirror; CD was external USB drive

Machine: VIA EPIA
Processor: C3 1GHz
Memory: 512MB
Root device: /dev/hda
Partition table:
  /dev/hda1   /boot       (75M)   [ext3]
  /dev/hda5   /           (530M)  [ext3]
  /dev/hda6   /usr        (5.5G)  [xfs]
  /dev/hda7   /var        (2G)    [xfs]
  /dev/hda8   /tmp        (1.2G)  [xfs]
  /dev/hda9   /home       (15G)   [xfs]
  /dev/hda10  /mnt/www    (1G)    [xfs]
  /dev/hda11  /mnt/media  (97.5G) [xfs]

Base system installation checklist:

Initial boot worked:      [O]
Configure network HW:     [O]
Config network:           [O]
Detect CD:                [O]
Load installer modules:   [O]
Detect hard drives:       [O]
Partition hard drives:    [O] **
Create file systems:      [O]
Mount partitions:         [O]
Install base system:      [O]
Install boot loader:      [O]
Reboot:                   [O]

  As marked with '**' above, there are certain issues with partitioning.
First, it is not exactly intuitive - the rest of the install is.
Secondly, a person doing a relatively secure install will find himself
shot on the foot. I chose mount options for /tmp: nodev,nosuid,noexec
this was a bad idea.

  After boot, installer tries to execute the actual system install. For
this, a script stored in /tmp is used. At the end of boot, the script
can't execute because of noexec. There are some errors and then init
will try to sleep. There is relatively little to do at this point.

  That was the first bug with partitioning. Solution would be to call
the second stage installer always with /bin/sh, not trying to execute it

  There was another issue with installer that I discovered because of
this. The installer (or its current revision at least) can not be used
as a rescue media. This is not the issue, but it caused the real

  Trying to do a reinstall: I was happy with the partition layout and
wouldn't have wanted to set it again; only wanted to remove the noexec
flag from /tmp. This proved to be impossible. The partitioning menu,
when faced with existing layout and filesystems, only displays three
selections. Editing the partition and its options is not one of them. (I
know I should have taken a shot of the menu but was too struck to think
of it.) In the end I didn't want to bother with trying to trick the
installer to work with me, so I went with a fresh install after all.
This time omitted noexec from /tmp. This install worked.

  There is one final issue with second stage of install. Setting up the
packages winds up in an error. Hitting enter on "Install selected
packages" results in apt-get pulling one more package (for my firewall
setup, it was python; for my would-be server, it was indent); after
that, the installation continues.

Mika Boström     \ /  "World peace will be achieved
Bostik@lut.fi     X    when the last man has killed
Security freak   / \   the second-to-last." -anon?

--- End Message ---
--- Begin Message ---
We've been offering a "rescue" boot option on various CDs for a long
time in testing, and now also in the Etch stable sets.

Steve McIntyre, Cambridge, UK.                                steve@einval.com
"This dress doesn't reverse." -- Alden Spiess

Attachment: signature.asc
Description: Digital signature

--- End Message ---

Reply to: