[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Test of el-torito and isolinux multiboot for CD


I did not test your multiboot system, and - apologies - I won't have
time to do so. However, I installed woody on a pentium 4 system a couple
of months ago. It had an Asus P4B - Board. I imagine these boards will
be pretty common now and you might receive some feedback about it. These
boards have a very annoying bios bug that makes booting Linux quite a

The following is an e-mail exchange I had with somebody about the
problem. Perhaps you find it helpful (if you don't decide to skip these
stupid boards which would sympathize with ...):

> Hi,
> I found a posting of you in
> http://www.mail-archive.com/debian-boot%40lists.debian.org/m
> sg13104.html
> (and previous message, same board). I have the same
> problem, though I
> tried it with various woody rescue.bins. Have you found a
> workaround? If
> so, do you feel inclined to telling me about it? ;-)
> I'd much appreaciate your help.
> If you can help me, please mail to schrotie@uni-bielefeld.de
> (charly.meyer@t-online.de is a friends account). Otherwise sorry for
> bothering.
> Cheers,
>    Thorsten

Hi Thorsten,

Yes, I have worked around the problem.  I won't get into the details
of why the failure occurs, but it is definitely a BIOS bug.  If you
want the details, just let me know.

The workaround requires that you be able to build a kernel on another
machine.  I'm not certain I remember everything.  Unfortunately, I
didn't keep my scratch notes:(

Build a kernel specific to the P4B machine.  Make sure the kernel
includes support for FAT -- not as a module.  You need FAT support so
the installation program can read the Debian rescue.bin disk, or else
it stops the installation cold.  It seems like there was another
kernel config that needed to be set, but I'm not sure.  Make sure
support for your NIC is compiled into the kernel, also.

dd your new kernel image to the floppy.  Then rdev it as follows:

rdev /dev/fd0 /dev/fd0
rdev -r /dev/fd0 49152

The floppy should be ready to go.  Insert it, cross your fingers and
boot up.  It will ask for the root disk and after that everything
proceeds as if normal.

Good luck.  If you run into snags, let me know.  I'll try to help as
much as possible.


BTW:  When you get a chance, complain to ASUS about the buggy BIOS.  I
did and also politely requested they become more open source friendly.

To UNSUBSCRIBE, email to debian-cd-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: