[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: jigdo 0.6.2

Richard Atterer écrivait/wrote:
> I've just uploaded Jigsaw Download 0.6.2. This version has only seen
> relatively light testing, I hope no bugs have crept in.
> What's new?
> ~~~~~~~~~~~
>   - gettext support (but no translations are present yet)
>   - Portability fixes to jigdo-lite (Anne Bezemer). I've only merged
>     some of Anne's changes, not all.
>   - Portability fixes to the jigdo-file code (for RedHat/Mandrake
>     systems, systems without <sstream> such as Debian Potato). Can
>     someone confirm that it compiles on potato now?

I currently use Progeny Debian (which is based on Potato), and I was unable 
to get jigdo to compile because of that sstream issue:

jigdo-file-cmd.cc:16: sstream: No such file or directory
make[1]: *** [jigdo-file-cmd.o] Error 1
make[1]: Leaving directory `/mnt/tmp/jigdo/jigdo-0.6.1/src'
make: *** [all] Error 2

That said, with this 0.6.2, I was able to compile, which is great! Thanks!

One more note on compiling, regarding GTK. I had 1.2.10-ximian.21 installed, 
and the configure script told me:

checking for GTK+ version... ./configure: gtk-config: command not found
   * GTK+ not installed, or the installed version is not
   * 1.2.x, or gtk-config is not in $PATH. Please
   * install GTK+ 1.2, it is needed by `jigdo'.

I searched a bit, and installed libgtk1.2-dev (1.2.10-ximian.21), which got 
recognized by the configure script:

checking for value of --with-libdb... "no"
checking for GTK+ version... 1.2.10
checking for libwww version... ./configure: libwww-config: command not found

I don't know if you have a deb-src package, but anyway, you might want to 
mention this.

In case you ask, jigdo does not install on Progeny Debian (~potato):

Sorry, but the following packages have unmet dependencies:
  jigdo: Depends: libc6 (>= 2.2.4-4) but 2.2.1-1.0progeny1 is to be installed
         Depends: libdb3 (>= 3.2.9-1) but it is not installable
         Depends: libstdc++2.10-glibc2.2 (>= 1:2.95.4-0.010810) but 
1:2.95.2-17 is to be installed
         Depends: libwww0 (>= 5.3.2-2) but it is not installable or
                  libwww-ssl0 (>= 5.3.2-2) but it is not installable
         Depends: xlibs (> 4.1.0) but 4.0.3-1 is to be installed

At least, it compiles, which is a pretty good thing. Thanks for the sstream 



Reply to: