[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

upgrade still not working good.

slink system, updated last a few weeks ago, tried to
update to potato with cd images as of 4.4.2000.

first "less /cdrom/*" does not give much usefull information.
also there are lots of compressed files, for example *.txt.gz.
i vote to decompress them.

dpkg-multicd could not resolve any dependencies to a usefull point,
the apt version had apt-cdrom, but it could change cd's.

so i had to manual update apt and later manual install adduser.

then it works nice, but several times the upgrade fails, and you
have to start "dselect->install" again. not a problem, since i see
that it had resolved some problems. but for unexperienced users
this is very strange.

i also saw that very often dpkg was invoked to install or upgrade
exactly one package. this slows everything down a lot, since dpkg
has to read the package datase again everytime.

also i had problems removeing kernel-image-2.2.9 and plan.
fixed them with hacking ("exit 0" in the ki229 postrm script/
created /var/lib/plan which did not exist before).

all in all it's a big improvement, but still i can not recommend the 
update procedure to anyone execpt hard core debian fanatics.

regards, andreas
p.s: this mail is send to debian-cdrom. if you find any other mailing list
usefull for this posting, please let me know. you can also forward the
posting, but make sure noone else does. i do not read -user, -devel, -private.

Reply to: