[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: potato-cd scripts: Necessary changes in CVS?

On 5/25/99, 5:03:20 PM, Brandon Mitchell <bmitch@surfree.com> wrote 
regarding Re: potato-cd scripts: Necessary changes in CVS?:

> On Tue, 25 May 1999, jim westveer wrote:

> > IMHO I think they should be NON-release specific.
> > ie debian-cd1 .. debian-cd2 ... etc
> > it may make it easier to use for the next release.

> It would be nice if it were possible.  I fear that the changes between
> releases would make this difficult though.  Packages are put on a disk
> because of size limits and demand/importance.  New packages and 
> packages are just two more variables.  If we try to guarantee that the
> current debian-cd scripts support slink, potato, and whatever else 
> up, each script will get even more complicated for a smaller gain.


I am somewhat familiar with slink_cd ;)  My remark is due to the fact
that :

1.) everything in slink_cd is called slink_something....
    It would be easier to read/debug if the distro name was 
    only used when refering to the distribution, not to a 
    psuedo list that is used for deciding what is on what disk;
    That is the function of slink1.info slinkx.extra etc etc.
    Those files infact just list what will be built on disk1
    disk2, diskx ....

2.) all lables do not have to start with the name of the distro.

3.) infact it would be easier to come up with a new cd_creation 
    script, if the name of the distribution was a variable,  one
    could then just change that variable, and then work on making
    sure that the "important" packages are on the appropriate disks.

Just my humble opinion.  No offense intended...


Jim Westveer <jwest@debian.org>

Jim Westveer                      LAN Comp Systems
jwest@netnw.com                   14524 Issaquah-Hobart Rd
425-392-0141 voice                Issaquah, WA 98027 USA
425-557-0660 fax                  lcs.issaquah.wa.us
Fingerprint = DC 49 E8 7E 76 DD 30 2D 8D F1 B4 D8 A3 60 4C 04

Reply to: