[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: symlink farm

Idiot report #7

Found the problem, and fixed it for me, but is there a generic solution?

Centres round line 536 in slink_cd,  cp -dpRPl $file .....

The symlinks of the mirror must match $file, otherwise slink_cd creates a
directory rather than a symlink to the directory on the other partition.

In my case, I have symlinks to the source directories on another partition
where I keep the source archive.  Fine for contrib etc as slink2.list
which matches my mirror symlink, however slink3.list specifies
	dists/slink/main/source/admin (etc)
and a /source directory in created and misses my symlink.
My solution was to symlink /admin, /base etc rather than /source to my
main mirror, so my mirror and slink3.list now match.

I hate to think what would happen if I tried to create the trees on the
patition I keep the source!!

Hope this helps.


On Thu, 28 Jan 1999, Steve McIntyre wrote:

> On Thu, 28 Jan 1999, Philip Charles wrote:
> >Idiot report #6,
> >
> >Being trying to use the symlink farm.  Results horrible.
> >
> >All source on one partition, binaries on another.  If I use the hard link
> >hack on each partiton the results are what one would expect, nice slink1,
> >(binary only), slink3 and slink4 (source only) the others a mess.  I
> >mention this to show that the hard link hack basically works for me.
> >
> >With the symlink farm there I experience widespread failures.  Symlinks
> >are not created.  There are error messages to this effect.  I have checked
> >for a permissions problem.
> OK... Can you send me log output? I may be able to track it down then...

Philip Charles; 39a Paterson St., Abbotsford, New Zealand; +64 3 4882818
For Debian GNU/Linux CDs see http://crash.ihug.co.nz/~philipc

Reply to: