[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#815328: python-llfuse: FTBFS on kfreebsd: unsatisfiable B-D: fuse

Nikolaus Rath wrote:
> Ah, ok. I guess it gives non-zero exact status if it doesn't find any
> tests to run at all.
> So the next question is why is it finding only one test, and why is it
> skipping that one.
> * Is there a "fusermount" executable available on kfreebsd?

No, but there is a mount_fusefs in package fuse4bsd.

Also I realised when I suggested before putting in Build-Depends:
    fuse [linux-any] | fuse4bsd [kfreebsd-any],
that actually does not do as intended unless written as:
    fuse [linux-any], fuse4bsd [kfreebsd-any],

> * Can you re-run with 'py.test-3 --collect-only test/'?

I tried on two different machines with the same result:
 1. a restricted chroot like on the buildds, clean up-to-date sid,
    without the fuse kernel module loaded, and no /dev/fuse;
 2. a local machine having the kernel module loaded, and /dev/fuse.

$ py.test-3 --collect-only test/ ; echo exit status $?
============================= test session starts ==============================
platform gnukfreebsd10 -- Python 3.4.4rc1, pytest-2.8.5, py-1.4.31, pluggy-0.3.1 -- /usr/bin/python3
cachedir: test/.cache
rootdir: /home/steven/python-llfuse-0.41.1+dfsg/test, inifile: pytest.ini
collected 0 items / 1 skipped 

========================== 1 skipped in 0.06 seconds ===========================
exit status 5

Steven Chamberlain

Attachment: signature.asc
Description: Digital signature

Reply to: