[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#815495: zeromq3: FTBFS on kFreeBSD: 'xucred cred' has incomplete type


I've tried 4.1.4-4 in a clean sid chroot on kfreebsd-amd64.

László Böszörményi (GCS) wrote:
> Strange that it's being run on your machine;
> disable-test_security_curve.patch disables this unconditionally. :-0

In 4.1.4-3, I don't think the patch was applied, and dpkg-source did not
run quilt during unpack.  In 4.1.4-4 that patch isapplied and that test
is no longer built or executed.

I had a few test failures this time, mostly relating to
suggesting the port was in use or maybe hadn't cleaned up properly after
a previous test run.  I don't have any daemons on that port.  I ran the
testsuite again a few minutes later and then all the tests passed.

> I don't see any difference even with passing VERBOSE=1 to
> dh_auto_test;

It is working.  You won't notice any difference unless there are test
failures, then it will `cat ./test-suite.log` into the build log with
the full error message of failed tests.  It's a feature of the test

Once this has been run on the buildds, I think you'll quickly find out
where the problem is.

> > Please see the attached, it will show the reason for test failures in
> > the build log, which should help figure out what is wrong on Linux.
>  First, may you test the proposed package update[1]? I've to guard the
> ucred.h inclusion as that's kFreeBSD only.

The guard should only be needed if Linux defines ZMQ_HAVE_SO_PEERCRED or
ZMQ_HAVE_LOCAL_PEERCRED.  Otherwise, sys/ucred.h is standard for
FreeBSD, but also NetBSD, Dragonfly, OS X too I think...

Steven Chamberlain

Attachment: signature.asc
Description: Digital signature

Reply to: