[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation problems


On 11/08/12 20:31, David Given wrote:
> - I had some trouble finding a mirror --- do not all of them carry kFreeBSD?

Perhaps many do not, especially the testing distribution.  I normally use:


(with the appropriate two-letter country code).

> - installing grub failed. I want grub in the FreeBSD partition, not the
> MBR, so this may not be a commonly tested path. It looks like it's
> unable to find a mapping between the BSD device name for the partition
> (/dev/ada0s6) and the BIOS drive.

That could be the recently-fixed grub-installer bug (#613430: /proc not
mounted in the target);  unfortunately the fix didn't make it into the
beta1 installer, but it should be fixed in sid_d-i daily builds;


A workaround is to drop into a shell when this happens, mount linprocfs
onto /target/proc and re-run that install step.

Installing directly to a UFS partition isn't something I've tried before

> - formatting the partition as UFS didn't remove the old jfs signature,
> which caused some confusion later when the partition was misdetected. I
> realise this isn't d-i's fault, but it was still awkward.

The formatting process for UFS should wipe the first and last 512 KiB of
the partition;  maybe that's not enough?

> I tried booting Linux Debian and running grub-update.
> It failed to find the kFreeBSD installation. This is grub-pc:amd64
> 1.99-22.1.

I'm not sure it's meant to, unless the kFreeBSD partition already
contains a valid bootloader for it to chain-load.

You could maybe repair the existing installation, by using the installer
in rescue mode:


After the extra installer components are loaded, drop to a shell, mount
the root filesystem, chroot into it, mount linprocfs on /proc, and retry
the installation of GRUB with:

# dpkg-reconfigure -plow grub-pc

...which lets you choose where to install it to, then I think it runs
update-grub automatically.

> Are these issues known about? Would you like formal bug reports?

It sounds like you hit a known issue in GRUB, but we should test that
installing GRUB to a UFS partition works properly now.  For the JFS
detection it might be worth filing a bug against ufsutils.

Either way, thanks for your feedback.

Steven Chamberlain

Reply to: