[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#651624: Booting from zfs root seems to not work 8.3 and 10.0 however work


I suspect this bug has nothing to do with the actual content of the
device.  Some hints:

  - It recently happened in one of my VMs.  Tried rebooting a few
times, always failed.  Then instead of reboot I shut down and restart,
then it works.  Disk content has to be exactly the same in all tests,
since nobody mounted it read-write.

  - In one of those reboots, I tried booting from a rescue disk (to
try to fiddle a bit with the data using "zpool import").  Then I found
that /dev nodes WERE NOT EVEN PRESENT.  Again, rebooting didn't help,
but after shut down and restart everything is back to normal.

  - Remember that "error 6" when the problem happens?  6 is ENXIO
(Device not present).

The picture begins to look like disks are not being detected.  GRUB is
not affected because it relies on the BIOS, and on VMs the BIOS is
likely to bypass the standard ATA interface.

Some tests that could confirm this, when any of us hits the problem again:

  - When you get the mount error, type "?" in mountroot prompt.  It
should give you a list of device nodes (e.g. ada0s2, ada0s1, ada0...).
 If it's empty, that's the reason it can't mount the ZFS root.

  - From GRUB prompt, try "insmod ata".  Then "ls" should give you a
list of disks, but this time using ATA rather than BIOS.  Check if
that list is empty.

Robert Millan

Reply to: