[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#613347: compatibility symlinks for libbsdxml

Package: libexpat1-dev
Version: 2.0.1-7
Severity: wishlist
User: debian-bsd@lists.debian.org
Usertags: kfreebsd

This library has the same API as the libbsdxml library that is used
on FreeBSD.  Obviously, when porting software from FreeBSD that
depends on libbsdxml, we adjust it to use Debian libexpat instead.

It would be easier though if libexpat provided compatibility symlinks
or another mechanism such that "#include <bsdxml.h>" works, and so
does "-lbsdxml" in linker flags.

Thanks for considering

-- System Information:
Debian Release: 6.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=ca_AD.UTF-8, LC_CTYPE=ca_AD.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libexpat1-dev depends on:
ii  libc6-dev [libc-dev]          2.11.2-10  Embedded GNU C Library: Developmen
ii  libexpat1                     2.0.1-7    XML parsing C library - runtime li

libexpat1-dev recommends no packages.

libexpat1-dev suggests no packages.

-- no debconf information

Reply to: