[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dependency strangeness (postfix/sasl2)

# apt-get install postfix
The following packages have unmet dependencies:
 postfix: Depends: libsasl2 (>= 2.1.19) but it is not going to be installed
I wonder what's going on? Isn't 2.1.22.dfsg1-8 supposed to
be >= 2.1.19 ?

The problem here is that libsasl2-2 has "Conflicts: postfix (<< 2.3.4-3)".
Unfortunately postfix does not build without extra patch,
so while in plain debian unstable is postfix 2.3.6-1,
kfreebsd have only package based on older version - 2.2.8-9+kbsd.

You can try to build postfix from source with patch
(based on) http://glibc-bsd.alioth.debian.org/patches/debian-only/postfix.diff
or extracted from http://ftp.gnuab.org/debian/pool-kfreebsd-i386/main/p/postfix/postfix_2.2.8-9+kbsd.diff.gz

Hope it helps.


Reply to: