[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

dh_suidregister bugs

# netkit-base
severity 83022 wishlist
severity 84827 wishlist
tag 84827 - wontfix
merge 83022 84827

# xcdroast
severity 83755 wishlist
severity 84497 wishlist
# (84497 seems a weird bug to have been reassigned)

# cgiwrap
severity 83834 wishlist

# innfeed
severity 83859 wishlist

# inn 
severity 84271 wishlist
# (also bug 84383, merged)

# masqmail
severity 84506 wishlist

# poppassd
severity 84551 wishlist

# mailman
severity 84554 wishlist

# netselect
severity 84565 wishlist

# ircd
severity 84567 wishlist

# hanterm
severity 84580 wishlist

# jfbterm
severity 84585 wishlist

# opie
severity 84590 wishlist

# typespeed
severity 84672 wishlist

# mutt
severity 84826 wishlist

# osh
severity 84870 wishlist

# rawrec
severity 85195 wishlist


These bugs are all "package with suid binaries use dh_suidregister, which
is now obsolete". This stopped packages from building with debhelper
versions >= 2.2.12 and << 3.0.0. Since the debhelper in testing is <<
2.2.12, and the debhelper in unstable is 3.0.0, this should mean all
these packages should be buildable again, which means none of the above
bugs need to be "serious" anymore (though not all of them were). Using
statoverride instead of suidmanager is still a Good Thing, though,
so they ought to stay open as wishlist requests.


Anthony Towns <aj@humbug.org.au> <http://azure.humbug.org.au/~aj/>
I don't speak for anyone save myself. GPG signed mail preferred.

``_Any_ increase in interface difficulty, in exchange for a benefit you
  do not understand, cannot perceive, or don't care about, is too much.''
                      -- John S. Novak, III (The Humblest Man on the Net)

Reply to: