[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#1035346: debian-installer: Failure to eject or recognize external media ejected

Package: debian-installer
Version: bookworm
Severity: important
Tags: d-i
X-Debbugs-Cc: budheal508@gmail.com

Dear Maintainer,

   * What led up to the situation?
Normal installation, full DVD set, USB (external) burner/reader
I selected Graphical mode but mostly used the keyboard
   * What exactly did you do (or not do) that was effective (or
Prior to this installation I was jumping the gun and pressing Continue as soon as the new disk was inserted. This got into a situation where I could not recover. There was no Back button and manually removing the disk and ineffective. This is emblematic of debian-installer's problem. I tried to submit this bug as grave but got no email response and cannot find the report.

This time I waited for each inserted disk to settle, as one would wait for apt;  before the system does not show the new volume has mounted, apt is likely to spit out another request for a media change.

If immediately pressing Enter after closing the disk's door, d-i usually worked but, for instance, the previous attempt d-i stalled on disk 3, where Back and Continue buttons did nothing and waiting or manually ejection did nothing. Power down is the only option. This, again, is something d-i should handle.

This bug is about a failure to recognize a media change at the end of installing the userland. Perhaps, fixing this will let the above bugs at least limp over the line. d-i asked to use "the drive '/media/cdrom'" and not cdrom0.

I checked every available option and selected LXDM; I tried SDDM earlier with similar results. That is, d-i asked for a media swap when done with disk 1.

Just before the GRUB step, d-i asks for a swap back to disk 1 but d-i will not recognize the burner's eject button has been pressed. There is a "Go Back" button and I had to clicked there twice before the main menu appeared and d-i finally recognized the reinserted disk. For good measure, I went back to the software installation step, which did nothing except exit normally, at which point GRUB did its things without further ado.

d-i will eject the external disk when asking the user to reboot into the new system, but everywhere else, misses the target. Maybe a fix here can propagate and fix all the problems listed above, some of which have been happening for many releases.

   * What was the outcome of this action?

I was able to install bookworm but only in an unexpected fashion.

   * What outcome did you expect instead?

d-i should allow the user to remove the external media practically at will. When the eject button is pressed, d-i should recognize that and unmount and eject the disk as soon as possible. If a disk is inserted, d-i should recognize the new disk as soon as the system mounts it.

-- System Information:
Debian Release: 12.0
Architecture: amd64 (x86_64)

Kernel: Linux 6.1.0-7-amd64 (SMP w/20 CPU threads; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Reply to: