[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#980271: #980271 installation-reports: Toshiba Tecra 8000 Installation report Bullseye

Control: reassign -1 pcmciautils
Control: tags -1 + patch

Charles Curley <charlescurley@charlescurley.com> wrote:
> I tried a Xircom CreditCard Ethernet adapter, CE38-100BTX, which uses
> the xirc2ps_cs driver. It runs, if slowly, on an installed system. But
> on installation, the software fails to detect it also.
> I noticed in the log on console F4 a message:
> pcmcia-socket-startup: chdir to /etc/pcmcia failed: no such file or
> directory.
> Possibly this is because the directory actually is /etc/pcmciautils on
> the installer. It is /etc/pcmcia on the installed system.
> I then made a symlink, rmmod yenta_socket, modprobe yenta_socket.
> Messages indicate that yenta_socket picked up the configuration file.
> I then inserted the card. Messages indicate that the card was detected
> and set up. I then went back to the installatio software, had it detect
> the network. It detected it correctly, and auto-configuration worked
> correctly.

I have verified that on a current testing installation system, there is
still /etc/pcmciautils/ existing, and no /etc/pcmcia/.

So re-assigning to pcmciautils package.

Also, I attached a patch, which should hopefully fix this for the udeb.


Holger Wansing <hwansing@mailbox.org>
PGP-Fingerprint: 496A C6E8 1442 4B34 8508  3529 59F1 87CA 156E B076
diff --git a/debian/changelog b/debian/changelog
index 44560d6..0c86fc6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+pcmciautils (018-13) UNRELEASED; urgency=medium
+  * Update /etc/pcmciautils/ dir to /etc/pcmcia/ in udeb.
+ -- Holger Wansing <hwansing@mailbox.org>  Thu, 21 Jan 2021 18:17:41 +0100
 pcmciautils (018-12) unstable; urgency=medium
   [ Bor GroÅ¡elj SimiÄ? ]
diff --git a/debian/pcmciautils-udeb.install b/debian/pcmciautils-udeb.install
index 6e4bf21..2010958 100644
--- a/debian/pcmciautils-udeb.install
+++ b/debian/pcmciautils-udeb.install
@@ -1,2 +1,2 @@
 lib/udev lib/
-usr/lib/pcmciautils/config.opts etc/pcmciautils/
+usr/lib/pcmciautils/config.opts etc/pcmcia/

Reply to: