[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#946118: synaptics touchpad does not work in debian installer graphical mode

Samuel Thibault, le mer. 04 déc. 2019 01:52:36 +0100, a ecrit:
> Thinking of it... IIRC the touchpad is not working on my DELL XPS13
> laptop in g-i.

Indeed, it doesn't work.

> What I can see of it on normal boot of installed system is:
> [    6.097298] input: DELL07E6:00 06CB:76AF Mouse as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-8/i2c-DELL07E6:00/0018:06CB:76AF.0002/input/input12
> [    6.097660] input: DELL07E6:00 06CB:76AF Touchpad as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-8/i2c-DELL07E6:00/0018:06CB:76AF.0002/input/input13
> [    6.098066] hid-generic 0018:06CB:76AF.0002: input,hidraw1: I2C HID v1.00 Mouse [DELL07E6:00 06CB:76AF] on i2c-DELL07E6:00
> and lsmod | grep i2c gives
> i2c_designware_platform    16384  0
> i2c_designware_core    20480  1 i2c_designware_platform
> i2c_i801               32768  0
> i2c_hid                28672  0
> hid                   126976  4 i2c_hid,usbhid,hid_multitouch,hid_generic
> I don't see the i2c_designware* modules in the g-i image, perhaps that
> needs to be included for some hardware?

I tried to rmmod i2c_designware_platform on my installed system, the
mouse stopped working, so it seems to be required, at the very least.

I tried to add i2c-modules to a g-i image, i2c_designware_platform
didn't get loaded automatically, and even loading it manually didn't
make the mouse detected.


Reply to: