[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#907768: debian-installer: gfx and txt installer fail on new System76 oryx pro 17in 1080P disp w nvidia GTX1070

Package: debian-installer
Severity: important
Tags: d-i

Dear Maintainer,

Booting to the installer on my new Oryx Pro is failing for both the text and
graphical installer.  I have produced a 5minute video showing exactly what it looks like:


When booting into the text installer, the screen is scaled so tiny it is only
1cm by 1cm, and tiled horizontally across the screen.  If you zoom in you can
see the screen is "really there" but it is so tiny you can't make out any of
the options.

When booting into the graphical installer, I just see a blank screen and the
machine seems to hang forever.

The machine came with ubuntu pre-installed and it boots into that system just fine.

I was able to reproduce this problem with the following images:

I confirmed the checksum of the ISO and the validity of the usb drive, and
confirmed it worked in another machine.

The machine includes both intel and nvidia graphics, which are switched by
software.  I have tried putting it in both NVIDIA and Intel graphics modes and
see the same behavior:

I've tried several boot parameters including "nomodeset" and "vga=<various
things>", DEBIAN_FRONT_END=text, fb=false, gfxpayload=1920x1080, etc.

When I boot into the ubuntu install, the native resolution appears to be 1920x1080.

Because I currently have it set to Intel graphics mode, the nvidia hardware
doesn't even show up in $(lspci), the intel hardware is "Intel Corporation
Device 3e9b" using kernel driver i915.  I can get the nvidia details if needed
but system76 says it is a 8GB GTX 1070.

I am filing this report from another machine, so the system information below
is not relevant.

I am happy to try things if you have any suggestions for a workaround, at this
point I have to imagine the possibilities are a (very very weird) hardware
problem, or a hardware incompatibility.

-Carl Myers

-- System Information:
Debian Release: 9.4
  APT prefers stable
  APT policy: (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.8.0-2-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Reply to: