[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Upcoming transition: libcryptsetup4 -> libcryptsetup12



Hi there,

the upcoming upload of cryptsetup 2.0.0-1 will bump the libcryptsetup
soname from 4 to 12. According to (the very thoughtful) upstream, the
API (old functions) is backwards-compatible, so simple rebuilds of the
reverse depenencies should be enough.

Here's a list of reverse depends:

bruteforce-luks
cryptmount
libpam-mount
luksmeta
systemd
volume-key
libblockdev
zulucrypt

Debian-boot is Cc'ed as cryptsetup provides udebs, so debian-installer
is affected as well.

How shall we proceed? The package is ready to be uploaded. Shall we go
ahead? Will you (the Release Managers) trigger the binary rebuilds
afterwards? Or can/shall we do this ourselves?

Cheers
 jonas

Attachment: signature.asc
Description: OpenPGP digital signature


Reply to: