[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#861380: Debian Stretch Installer RC3 fails to boot kernel on Lenovo P51 laptop (Kaby Lake and Quadro M2200M)

Package: installation-reports

Boot method: Stretch Installer on USB stick, created from hybrid ISO-DVD image Image version: http://cdimage.debian.org/cdimage/stretch_di_rc3/amd64/iso-dvd/debian-stretch-DI-rc3-amd64-DVD-3.iso
Date: several times between April 25 to April 27 2017

Machine: Lenovo Thinkpad P51
Processor: i7-7820HQ
Memory: 16GB
Partitions: N/A

Output of lspci -knn (or lspci -nn): N/A

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [E]
Detect network card:    [ ]
Configure network:      [ ]
Detect CD:              [ ]
Load installer modules: [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Install base system:    [ ]
Clock/timezone setup:   [ ]
User/password setup:    [ ]
Install tasks:          [ ]
Install boot loader:    [ ]
Overall install:        [ ]


Debian Stretch Installer RC3 fails to boot the linux kernel.

<Description of the install, in prose, and any thoughts, comments and ideas you had during the initial install.>

The installation gets stuck with a black screen (no cursor, backlight on, only Ctrl-Alt-Del sometimes restarts the system) and an unresponsive system reproducibly when trying to boot the linux kernel from the USB stick. This happens both with the DVD-ISO of RC3 and the “unofficial” Installer Image that contains non-free firmware from http://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/weekly-builds/amd64/iso-dvd/firmware-testing-amd64-DVD-1.iso More precisely, once GRUB2 tries to boot the kernel, the screen becomes entirely black and stays so; after a short time (perhaps 2-3s), the LEDs indicate that the SSD is accessed (for a very short time). After that, the system is sometimes completely unresponsive, at other times, one can reboot using Ctrl-Alt-Del (which makes the LEDs indicate another access to the SSD). I was unable to produce any graphics or textual output that would allow me to provide further debugging information.

GRUB2 succeeds in starting up using UEFI and displays the initial dialog which presents the “Graphical”, “Install”, etc. boot options. On the GRUB2 command line, one can successfully access the partitions on the USB stick that contain the Linux kernel. Therefore, the problem is probably not related to the creation of the USB stick or the UEFI boot method. Apart from the standard configuration for a graphical and a text-mode installation, I tried to boot with several combinations of kernel boot parameters (rather randomly, I admit), but none of them worked:
-	nomodeset
-	gfxpayload=keep
-	vga=normal
-	nosplash
-	pci=noacpi

The Ubuntu 17.04 installer images manage to boot successfully; they are using a more recent kernel (4.10 on Ubuntu vs. 4.9 on Debian Stretch’s installer).

Reply to: