[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#855415: installation-reports: Debian-Testing fails to reboot after installation.

Control: tag -1 moreinfo

On Fri, 2017-02-17 at 19:14 +0100, Michael Siemmeister wrote:
> Last week I tried to install Debian in a virtual-box. Currently I use
> Debian 8.7 for running the virtual-box program. I managed to install
> Debian stable without any problems. Then I cloned the virtual-box and
> tried an upgrade to Debian-testing. I think, it worked. After a while
> I shut down the virtual-machine. When trying to reboot, it did not
> start properly. I just got some messages like 'Created slice User
> Slice of Debian-gdm.', 'Starting User Manager ofr UID 117.', and
> finally 'Started Daily apt activities.'. Then the virtual display just
> starts blinking. Nothing else happens. After three minutes or so the
> display freezes.

It seems that the X or Wayland server is not starting because something
is wrong with a graphics driver.  gdm will try to start it several
times before giving up.  This can cause the blinking that you see.  Try
switching to another VT (e.g. press Alt-F2).  You should get a text
login prompt that you can use to start a shell.

You should be able to find some information about what went wrong with
this command:

    sudo grep gdm /var/log/messages

I hope you can work out how to copy that text into a file and then an
email; if not then ask about this on debian-user.

> Nevertheless, as written in my first mail, I got problems with
> installing Debian-Testing on my old Toshiba laptop. I just checked the
> model number. It's a Toshiba Satellite P300-1BB. Model No.:
> PSPCCE-01K001GR. Debian-Stable Jessie 8.5 worked fine without any
> problems during the installation. So I think the hardware is okay.
>  I tried to install Debian-Testing on this laptop directly to the
> harddisk without virtualbox. During the installation there were no
> problems. But after the first boot, I keep getting these messages:
> [drm:radeon_pci_probe [radeon]] *ERROR* radeon kernel modesetting for
> R600 or later requires firmware-amd-graphics.
> kvm: disabled by bios
> Then the display starts blinking and nothing else happens.

You need to log in (as explained above), enable non-free packages (see
https://wiki.debian.org/SourcesList), and install the firmware-amd-
graphics package.  Then you should probably reboot.

Alternately, reinstall using an installer built with non-free firmware


Ben Hutchings
Any sufficiently advanced bug is indistinguishable from a feature.

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: