[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#855415: installation-reports: Debian-Testing fails to reboot after installation.

Package: installation-reports
Severity: important

Dear Maintainer,

* What led up to the situation?
I first tried the mailing-list: https://lists.debian.org/debian-user/2017/02/msg00602.html

---just copied from the mailing-list---
Last week I tried to install Debian in a virtual-box. Currently I use
Debian 8.7 for running the virtual-box program. I managed to install
Debian stable without any problems. Then I cloned the virtual-box and
tried an upgrade to Debian-testing. I think, it worked. After a while
I shut down the virtual-machine. When trying to reboot, it did not
start properly. I just got some messages like 'Created slice User
Slice of Debian-gdm.', 'Starting User Manager ofr UID 117.', and
finally 'Started Daily apt activities.'. Then the virtual display just
starts blinking. Nothing else happens. After three minutes or so the
display freezes.

Then I thought, okay, maybe the virtualbox program has got a bug. So,
I downloaded the Debian-Testing-DVD-1 via jigdo-lite and copied it to
a USB drive. I tried to install Debian-Testing on an old laptop, a
Toshiba Satellite from 2009. Unfortunately I don' remember the exact
model number. I had already installed Debian Stable without any
problems on that laptop some months ago. The Debian-Testing installer
worked fine and finally, it asked me to reboot the PC. After rebooting
similar problems occured. There was a message about the graphics card
and after 30 seconds the display started blinking. Nothing else

As I have written above these errors only occured with Debian-Testing.
Debian-Stable worked fine on Virtualbox and the Toshiba laptop. So, I
don't think there are some hardware problems.
---END of copied text---

Nevertheless, as written in my first mail, I got problems with
installing Debian-Testing on my old Toshiba laptop. I just checked the
model number. It's a Toshiba Satellite P300-1BB. Model No.:
PSPCCE-01K001GR. Debian-Stable Jessie 8.5 worked fine without any
problems during the installation. So I think the hardware is okay.

 I tried to install Debian-Testing on this laptop directly to the
harddisk without virtualbox. During the installation there were no
problems. But after the first boot, I keep getting these messages:

[drm:radeon_pci_probe [radeon]] *ERROR* radeon kernel modesetting for
R600 or later requires firmware-amd-graphics.
kvm: disabled by bios

Then the display starts blinking and nothing else happens.
---END of copied text---

* What exactly did you do (or not do) that was effective (or
As suggested in the mailing list I tried 'nomodeset':
---copied from mailing list---
I just tried it. Since I did not know anything about 'nomodeset', I
looked for it on the internet. I found this link:


and followed it until step 5, so I did: 
2. After completion reboot the server as normal but interrupt the
default boot in GRUB by hitting the arrow keys.
3. Highlight the very first, top option and hit 'e'
4. Scroll down on the editor and look for the line that starts with
'linux'. Once found append to the end of the line with 'nomodeset'
5. Press 'F10' to boot. The server should boot and not disconnect if
done correctly.

I am not sure if I have done it correctly. The 'linux' line looked as
follows before pressing 'F10'.

linux /boot/vmlinuz-4.9.0-1-amd64 root=UUID=<a lot of numbers> ro quiet
(it is one line originally, despite being two in this mail)

The result was:

[drm:radeon_init [radeon]] *ERROR* No UMS support in radeon module!
kvm: disabled by bios
kvm: disabled by bios

Then the screen started blinking again.
---END of copied text---

-- Package-specific info:

Boot method: USB-drive
Image version: Debian-Testing, 2017-02-06 (I think so)
Date: 2017-02-15 

Machine: Toshiba Satellite P-300-1BB
Partitions: I don't know. Just selected automatic partitioning or something like this. 

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [E]
Detect network card:    [ ]
Configure network:      [ ]
Detect CD:              [ ]
Load installer modules: [ ]
Clock/timezone setup:   [ ]
User/password setup:    [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Install base system:    [ ]
Install tasks:          [ ]
Install boot loader:    [ ]
Overall install:        [ ]

The installation process went smoothly. The first problems occured after the suggested reboot(after GRUB installation it asks you to reboot). I have written about my problems above.


Reply to: