[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#853927: debian-installer: Hang in os-prober in "dmsetup create -r osprober-linux-sda1"


Brainslug <brainslug@freakmail.de> (2017-02-15):
> 	I tried installing RC2 (netboot) on my ASUS TP200SA yesterday and ran
> into a similar issue, os-prober hang during the install-grub phase. The
> thing here is that I'm neither using LVM nor any crypto, just the plain
> eMMC with a couple of partitions (see below).
> I could successfully finish the installation by manually killing the
> os-prober processes (there were multiple running) and then trying the
> GRUB re-install again via the install menu. The second time it worked.
> After I finished the installation I decided to try again, restarted a
> fresh installation and same thing - os-prober would hang on the first
> attempt but finish without any issues after killing and re-trying.
> Not sure if this any useful info but I thought I'd mention it b/c I
> don't see any reports for plain, non-encrypted, non-LVM disks showing
> this issue.
> But maybe it's a completely different problem?

I'm interested in knowing which partition(s) it was hanging on. Do you
remember? Or can you check your installer's syslog (you'll find it as
/var/log/installer/syslog on the installed system).


(I'll be trying to reproduce this issue with various configurations, but
the more I know about the broken one, the quicker I'll figure it out.


Attachment: signature.asc
Description: Digital signature

Reply to: