[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#777526: debian-installer: when installing xfce system only, quodlibet installed and gstreamer pulse module not



reassign 777526 quodlibet
retitle 777526 redundant dependency on gstreamer1.0-audiosink which is provided by gstreamer1.0-plugins-good
found 777526 3.6.2-1
thanks

On Mon, 09 Feb 2015 02:52:26 -0600 Joseph Lenox
<lenox.joseph@gmail.com> wrote:
> Package: debian-installer
> Version: 8.0
> Severity: important
> 
> Dear Maintainer,
> 
> After installing a fresh Jessie install, I tried to start quodlibet
> and noticed that I was getting no sound. I traced this to the
> gstreamer plugin for pulseaudio not being installed. While quodlibet
> does not necessarily pull this package in (as it's only necessary
> when pulseaudio is installed and that isn't always the case), I
> suspect it should be added to the package install list for the xfce
> desktop environment, as gstreamer and quod libet are included.
> 
> I was able to resolve my problem by installing
> gstreamer1.0-pulseaudio.
> 
> I expected the necessary packages to be installed without having to
> go hunting for it myself.

quodlibet gets installed by task-xfce-desktop and quodlibet depends on 
gstreamer1.0-pulseaudio | gstreamer1.0-audiosink. quodlibet also
depends on gstreamer1.0-plugins-good which Provides:
gstreamer1.0-audiosink.

Therefore, the | gstreamer1.0-audiosink part of the dependency
duplicates the existing dependency on gstreamer1.0-plugins-good.

Depends: python (>= 2.7.3-4+deb7u1), exfalso (= 3.2.2-1),
gir1.2-gstreamer-1.0, gir1.2-gst-plugins-base-1.0,
gstreamer1.0-plugins-base, gstreamer1.0-plugins-good,
gstreamer1.0-plugins-ugly, gstreamer1.0-pulseaudio |
gstreamer1.0-audiosink

$ apt-cache show gstreamer1.0-plugins-good|grep Provides
Provides: gstreamer1.0-audiosink, gstreamer1.0-audiosource,
gstreamer1.0-videosink, gstreamer1.0-videosource,
gstreamer1.0-visualization

quodlibet should have:

Depends: gstreamer1.0-plugins-good, gstreamer1.0-pulseaudio
or
Depends: gstreamer1.0-plugins-good
Recommends: gstreamer1.0-pulseaudio
or
Depends: gstreamer1.0-plugins-good | gstreamer1.0-pulseaudio

This bug is still present in unstable, quodlibet 3.6.2-1.

> 
> 
> -- System Information:
> Debian Release: 8.0
>   APT prefers testing-updates
>   APT policy: (500, 'testing-updates'), (500, 'testing'), (1,
> 'experimental') Architecture: amd64 (x86_64)
> Foreign Architectures: i386
> 
> Kernel: Linux 3.16.0-4-amd64 (SMP w/8 CPU cores)
> Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
> Shell: /bin/sh linked to /bin/dash
> Init: systemd (via /run/systemd/system)
> 
> 



-- 


Neil Williams
=============
http://www.linux.codehelp.co.uk/

Attachment: pgpOCWgSqj_fI.pgp
Description: OpenPGP digital signature


Reply to: